Talk:Install Slackware Using A USB Flash Drive

From SlackWiki
Jump to navigation Jump to search


I'm new to slackware. I tried installing it as given in the wiki page. But ran into trouble in the last stage. First of all, fdisk -l shows sdb - 16 gb(usb size), sdb1 (4 gb) and sdb1p1 (similar size). What is sdb1p1? Which one do I mount? I decided to mount sdb1.

After mounting and running setup, I set up the targets \home, \usr etc. Then it says it has detected FAT/NTFS filesystem (the usb in all probability) and if I want to add that to fstab. I tried different things here. Since the usb is already mounted, I first tried answering no and going to install. Later I tried mounting sdb1 in flash at this step again and then running install. In both cases, when I select "install from hard disk partition" and select source partition as "/dev/sdb1" and then source path as "/slackware" or "/flash/slackware" or "slackware", it says "error mounting, should I continue". I tried using install option "pre-mounted directory" and gave "/flash/slackware" as the directory but it couldn't find the directory. What am I doing wrong?


I had the same issue.

You have to select "Install from a Slackware CD or DVD" then select custom. Enter the device path ex. /dev/sdb1. Installatin should proceed as normal. The reason for this is that installing from hard disks option does not support iso9660 filesystem.

Hope this helps,

Best wishes, Zoltan